<!doctype html>
      <html class="single desktop fixed-full-width" lang="en">
        <head>
          <title data-react-helmet="true">Governor Whitmer Biggest Hypocrite To Hold The Office?</title>
          <meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" charset="UTF-8"/><meta data-react-helmet="true" name="description" content="I can rally and campaign you can not President Trump."/><meta data-react-helmet="true" name="keywords" content="president trump whitmer rally george floyd civil rights deny ban,michigan,opinion,politics"/><meta data-react-helmet="true" property="fb:app_id" content="562523347161546"/><meta data-react-helmet="true" property="fb:admins" content="100002025987268"/><meta data-react-helmet="true" property="fb:admins" content="664423889"/><meta data-react-helmet="true" property="og:title" content="Michigan’s Governor Whitmer Biggest Hypocrite To Hold The Office? Block Trump Rally? Join Floyd Rally!"/><meta data-react-helmet="true" property="og:description" content="I can rally and campaign you can not President Trump."/><meta data-react-helmet="true" property="og:url" content="https://wbckfm.com/michigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally/"/><meta data-react-helmet="true" property="og:site_name" content="95.3 WBCKFM"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="og:image" content="https://townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg?w=1200&amp;h=0&amp;zc=1&amp;s=0&amp;a=t&amp;q=89"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@wbcknews"/><meta data-react-helmet="true" name="sailthru.description" content="I can rally and campaign you can not President Trump."/><meta data-react-helmet="true" name="sailthru.date" content="2020-06-26 05:56:58"/><meta data-react-helmet="true" name="sailthru.title" content="Michigan’s Governor Whitmer Biggest Hypocrite To Hold The Office? Block Trump Rally? Join Floyd Rally!"/><meta data-react-helmet="true" name="sailthru.tags" content="tsmsite-wbck, tsmmarket-battlecreek, tsmtype-local, campaign, gretchen-whitmer, president-trump, michigan, opinion, politics"/><meta data-react-helmet="true" name="sailthru.author" content="renk"/><meta data-react-helmet="true" name="sailthru.image.full" content="https://townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg"/><meta data-react-helmet="true" name="sailthru.image.thumb" content="https://townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg"/><meta data-react-helmet="true" property="fb:pages" content="192937086432"/><meta data-react-helmet="true" name="google-site-verification" content="Fli18l0HwWiXWzWRSIwdnRoOvdiryfR1iqanc3TakLM"/><meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" name="viewport" content="width=1286, initial-scale=1.0"/><meta data-react-helmet="true" name="robots" content="max-image-preview:large"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=f98e05a2fb1ab4a264b745a44f08c7445be5c3b0&mver=4" as="style"/>
          <script>(function(){
        var
          hasConsented = RegExp( "gdpr_consent[^;]+" ).exec( document.cookie ),
          isEU = RegExp( "gdpr-source[^;]+" ).exec( document.cookie ),
          isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
        if( !hasConsented && ( isEU || isUS ) ){
          var cookieDupe=Object.getOwnPropertyDescriptor(Document.prototype,"cookie")||Object.getOwnPropertyDescriptor(HTMLDocument.prototype,"cookie");cookieDupe&&cookieDupe.configurable&&Object.defineProperty(document,"cookie",{get:function(){return cookieDupe.get.call(document)},set:function(n){if(n.search(/gdpr_consent|euconsent|brave-overlay|usprivacy/)===-1)return!0;cookieDupe.set.call(document,n)}});
        }
      })();</script>
          <link data-react-helmet="true" id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/656/files/2013/12/favicon.ico"/><link data-react-helmet="true" id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/656/files/2013/12/favicon.ico"/><link data-react-helmet="true" rel="profile" href="http://gmpg.org/xfn/11"/><link data-react-helmet="true" rel="prev" title="Court Shuts Down Line 5 – Temporarily" href="https://wbckfm.com/court-shuts-down-line-5-temporarily/"/><link data-react-helmet="true" rel="next" title="Whitmer Was Warned About Sending COVID-19 Patients To Nursing Homes &amp; She Ignored Those Warnings" href="https://wbckfm.com/whitmer-was-warned-about-sending-covid-19-patients-to-nursing-homes-she-ignored-those-warnings/"/><link data-react-helmet="true" rel="canonical" href="https://wbckfm.com/michigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally/"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?h=57&amp;w=57"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?h=114&amp;w=114"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?h=72&amp;w=72"/><link data-react-helmet="true" rel="alternate" hreflang="en" href="http://wbckfm.com/michigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally/"/>
          <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" />
          <link href="/styles/desktop/base.css?ver=f98e05a2fb1ab4a264b745a44f08c7445be5c3b0&mver=4" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(e,t={}){return new Promise(function(n,r){var i=function(e){e.target.removeEventListener("load",i),n(e.target)},o=document.createElement("script");for(var a in o.addEventListener("load",i),o.src=e,t)o.setAttribute(a,t[a]);document.body.appendChild(o)})};;
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"wbckfm.com","blogId":656,"method":"get_single","postId":157596,"postType":"post","postDateGmt":"2020-06-26 09:56:58.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/carbon/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"renk","dimension2":"michigan,opinion,politics","dimension3":"campaign,gretchen-whitmer,president-trump","dimension4":"post","dimension5":"Fri Jun 26 2020","dimension6":"05:56","dimension7":"standard","dimension8":"4180","dimension9":"A","dimension10":"yes","dimension12":""};
window.globalDimensionData = {"dimension1":"renk","dimension2":"michigan,opinion,politics","dimension3":"campaign,gretchen-whitmer,president-trump","dimension4":"post","dimension5":"Fri Jun 26 2020","dimension6":"05:56","dimension7":"standard","dimension8":"4180","dimension9":"A","dimension10":"yes","dimension12":""};
ga( "create", {
          trackingId:"UA-45678904-2",
          name: "primary",
          allowAnchor: false
        });
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-45678904-2"};
ga( "create", {
          trackingId:"UA-19109753-1",
          name: "UA191097531",
          allowAnchor: false
        });
        ga( "UA191097531.require", "displayfeatures" );
        ga( "UA191097531.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191097531.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191097531" ] = {gaid:"UA-19109753-1"};
ga( "create", {
          trackingId:"UA-45678904-1",
          name: "UA456789041",
          allowAnchor: false
        });
        ga( "UA456789041.require", "displayfeatures" );
        ga( "UA456789041.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA456789041.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA456789041" ] = {gaid:"UA-45678904-1"};
ga( "create", {
          trackingId:"UA-28825804-3",
          name: "UA288258043",
          allowAnchor: false
        });
        ga( "UA288258043.require", "displayfeatures" );
        ga( "UA288258043.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA288258043.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA288258043" ] = {gaid:"UA-28825804-3"};
ga( "create", {
          trackingId:"UA-45260060-4",
          name: "UA452600604",
          allowAnchor: false
        });
        ga( "UA452600604.require", "displayfeatures" );
        ga( "UA452600604.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452600604.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452600604" ] = {gaid:"UA-45260060-4"};
ga( "create", {
          trackingId:"UA-45678904-5",
          name: "UA456789045",
          allowAnchor: false
        });
        ga( "UA456789045.require", "displayfeatures" );
        ga( "UA456789045.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA456789045.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA456789045" ] = {gaid:"UA-45678904-5"};
            })(window);
          </script>
          <script async src="https://www.google-analytics.com/analytics.js"></script>
          <script async src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Governor Whitmer Biggest Hypocrite To Hold The Office?","callsign":"WBCKFM","market":"Battle Creek","sitetype":"Local","siteClassification":"Local","state":"MI","genre":"news-talk","pageType":"post","tags":"campaign,gretchen-whitmer,president-trump","categories":"michigan,opinion,politics","mediaType":"gallery"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");});</script>
          <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              hasConsented = RegExp( "gdpr_consent[^;]+" ).exec( document.cookie ),
              isEU = RegExp( "gdpr-source[^;]+" ).exec( document.cookie ),
              isUS = RegExp( "gdpr-source[^;]+" ).exec( document.cookie );
            if( ( !isEU && !isUS ) || ( isEU && hasConsented ) || ( isUS && hasConsented ) ){
              if( dl && dl[0] ){
                dl = dl[0];
                w._oiqq = w._oiqq || [];
                var keywordMeta = document.querySelector( "meta[name='keywords']");
                _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                _oiqq.push(["oiq_doTag"]);
                _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
              }
              var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true;
              oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
              var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
            }
          })(window, window.dataLayer);
        });
      </script>
          
          
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("//action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=WBCKFM&ncv=24");
      });</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile( "//d15kdpgjg3unno.cloudfront.net/oPS.js", {"data-cid": "58", id: "optimera-ops"} );
      });</script>
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6665296" });
        (function() {
          var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
          el.parentNode.insertBefore(s, el);
        })();
      });</script>
          
          <script>
      (function(window) {
        window.cmpFactory = function( varName ) {
          var
            listen = window.attachEvent || window.addEventListener,
            isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
          listen('message', function(event) {
            window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
          });

          var commandQueue = [];
          var cmp = function(command, parameter, callback) {
            if( command === "ping" ){
              callback({cmpLoaded: false}, true);
            }else{
              commandQueue.push({
                command: command,
                parameter: parameter,
                callback: callback
              });
            }
          };
          cmp.commandQueue = commandQueue;
          cmp.receiveMessage = function(event) {
            var data = event && event.data && event.data[ varName + "Call" ];
            if (data) {
              commandQueue.push({
                callId: data.callId,
                command: data.command,
                parameter: data.parameter,
                event: event
              });
            }
          };
          cmp.config = {};
          if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
            cmp.config.logging = "debug";
          }
          return cmp;
        };
        window.__cmp = window.cmpFactory( "__cmp" );
        window.__uspapi = window.cmpFactory( "__uspapi" );
      })(window);
    </script>
    <script async src="//townsquare.media/public/resources/js/cmp.bundle.js"></script>
          <script type="text/javascript" src="//doi3unldljdx6.cloudfront.net/script.js"></script><script async type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=wbckfm.com&v=f98e05a2fb1ab4a264b745a44f08c7445be5c3b0&mver=4"></script>

<script>!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag"};if(window.__uspapi){__uspapi("getUSPData", 1, function(r){params.us_privacy=r?(r.uspString||"1---"):"1---";apstag.init(params);})}else{apstag.init(params);}</script>

<script async='async' data-cfasync='false' src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=AQIWQ5-rSHOajREf3hV1Fg'></script>
<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '631470830669776');
    fbq('track', 'PageView');</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "wbckfm.com";ZERG.user = 751;</script>
        </head>
        <body>
          <div id="fb-root"></div>
          <div id="app"><div><div id="site-menu-wrapper" class=""><div class="site-menu-drawer"><ul class="promo-links"><li><span>Quick Links:</span></li><li><a title="Coronavirus- Latest News" href="/tags/coronavirus">Coronavirus- Latest News</a></li><li><a title="Online Job Fair" href="/tags/online-job-fair/">Online Job Fair</a></li><li><a title="Roofsit 2020" href="/tags/roof-sit-2020-battle-creek/">Roofsit 2020</a></li><li><a title="Open For Business Submission" href="/southwest-michigan-is-open-for-business/">Open For Business Submission</a></li><li><a title="Open For Business" href="/tags/open-for-business/">Open For Business</a></li><li><a title="Missing Persons" href="/tags/missing/">Missing Persons</a></li><li><a title="Seize The Deal" href="https://www.seizethedeal.com/cities/sw-michigan">Seize The Deal</a></li><li><a title="Podcasts" href="/category/podcasts/">Podcasts</a></li><li><a title="Closings &amp; Cancellations" href="/school-closings-delays/">Closings &amp; Cancellations</a></li><li><a title="App" href="/app/">App</a></li><li><a title="Alexa" href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/">Alexa</a></li><li><a title="Google Home" href="/googlehome/">Google Home</a></li><li><a title="High School Sports Scores" href="/battle-creek-area-high-school-sports-scoreboard/">High School Sports Scores</a></li></ul></div><div id="site-menu-bg"></div><a class="logo" href="/" itemProp="logo url" alt="95.3 WBCKFM" title="95.3 WBCKFM"><img src="//townsquare.media/site/656/files/2017/12/wbckfm-logo.png" alt="95.3 WBCKFM" title="95.3 WBCKFM"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"><a class="sign-in-out" href="/#auth-start" title="Click to Sign In" data-source="site login">Sign In</a></div><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/">Home</a></li><li class="hassub"><a href="/djs">On-Air</a><ul class="links submenu"><li class="hassub"><a href="/shows">Schedule</a></li><li class="hassub"><a href="/author/timcollins/">Tim Collins</a></li><li class="hassub"><a href="/author/jimmishler/">Jim Mishler</a></li><li class="hassub"><a href="/author/renk/">Renk</a></li><li class="hassub"><a href="/author/lacyjames/">Lacy James</a></li><li class="hassub"><a href="/author/nateadams/">Nate Adams</a></li><li class="hassub"><a href="/author/bradcarpenter">Brad Carpenter</a></li><li class="hassub"><a href="/author/alexmaddix/">Alex Maddix</a></li></ul></li><li class="hassub"><a href="/listen-live">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live">Listen Live</a></li><li class="hassub"><a href="/category/podcasts/">Podcasts</a></li><li class="hassub"><a href="/app">Mobile App</a></li><li class="hassub"><a href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/">Listen on Amazon Alexa</a></li></ul></li><li class="hassub"><a href="/events-battle-creek">Events</a><ul class="links submenu"><li class="hassub"><a href="/events-battle-creek">Community Calendar</a></li><li class="hassub"><a href="/events-battle-creek/community/add/">Submit An Event</a></li></ul></li><li class="hassub"><a href="/vip">VIP</a><ul class="links submenu"><li class="hassub"><a href="/registration">Join Now</a></li><li class="hassub"><a href="/contests/">Contests</a></li><li class="hassub"><a href="/contest-rules/">Contest Rules</a></li><li class="hassub"><a href="/help/">VIP Support</a></li></ul></li><li class="hassub"><a href="/battle-creek-weather/">Weather</a><ul class="links submenu"><li class="hassub"><a href="/battle-creek-weather/">5-Day Forecast</a></li><li class="hassub"><a href="/school-closings-delays/">Closings</a></li></ul></li><li class="hassub"><a href="/category/sports/">Sports</a><ul class="links submenu"><li class="hassub"><a href="http://www.brownbearsw.com/cal/bcradiosports" target="_blank">Radio Sports Schedule</a></li></ul></li><li class="hassub"><a href="/local-experts/">Experts</a><ul class="links submenu"><li class="hassub"><a href="/tags/newrides">Nico &amp; Tim&#x27;s New Rides</a></li><li class="hassub"><a href="/local-experts/darrell-burke-construction/">Darrell Burke Construction</a></li></ul></li><li class="hassub"><a href="/newsletter">Newsletter</a></li><li class="hassub"><a href="/help">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback">Send Feedback</a></li><li class="hassub"><a href="mailto:tim@wbckfm.com">E-mail Tim Collins</a></li><li class="hassub"><a href="mailto:renk@townsquaremedia.com" target="_blank">E-mail Renk</a></li><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities">Jobs</a><ul class="links submenu"><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities/">Townsquare Media Jobs</a></li><li class="hassub"><a href="/eeo/">EEO Report</a></li></ul></li><li class="hassub"><a href="/advertise">Advertise</a></li></ul></li><li class="hidden-menu hassub hide"><a class="more-icon" href="#">More</a><ul class="links submenu"><li class="hassub hide"><a href="/">Home</a></li><li class="hassub hide"><a href="/djs">On-Air</a><ul class="links submenu"><li class="hassub"><a href="/shows">Schedule</a></li><li class="hassub"><a href="/author/timcollins/">Tim Collins</a></li><li class="hassub"><a href="/author/jimmishler/">Jim Mishler</a></li><li class="hassub"><a href="/author/renk/">Renk</a></li><li class="hassub"><a href="/author/lacyjames/">Lacy James</a></li><li class="hassub"><a href="/author/nateadams/">Nate Adams</a></li><li class="hassub"><a href="/author/bradcarpenter">Brad Carpenter</a></li><li class="hassub"><a href="/author/alexmaddix/">Alex Maddix</a></li></ul></li><li class="hassub hide"><a href="/listen-live">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live">Listen Live</a></li><li class="hassub"><a href="/category/podcasts/">Podcasts</a></li><li class="hassub"><a href="/app">Mobile App</a></li><li class="hassub"><a href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/">Listen on Amazon Alexa</a></li></ul></li><li class="hassub hide"><a href="/events-battle-creek">Events</a><ul class="links submenu"><li class="hassub"><a href="/events-battle-creek">Community Calendar</a></li><li class="hassub"><a href="/events-battle-creek/community/add/">Submit An Event</a></li></ul></li><li class="hassub hide"><a href="/vip">VIP</a><ul class="links submenu"><li class="hassub"><a href="/registration">Join Now</a></li><li class="hassub"><a href="/contests/">Contests</a></li><li class="hassub"><a href="/contest-rules/">Contest Rules</a></li><li class="hassub"><a href="/help/">VIP Support</a></li></ul></li><li class="hassub hide"><a href="/battle-creek-weather/">Weather</a><ul class="links submenu"><li class="hassub"><a href="/battle-creek-weather/">5-Day Forecast</a></li><li class="hassub"><a href="/school-closings-delays/">Closings</a></li></ul></li><li class="hassub hide"><a href="/category/sports/">Sports</a><ul class="links submenu"><li class="hassub"><a href="http://www.brownbearsw.com/cal/bcradiosports" target="_blank">Radio Sports Schedule</a></li></ul></li><li class="hassub hide"><a href="/local-experts/">Experts</a><ul class="links submenu"><li class="hassub"><a href="/tags/newrides">Nico &amp; Tim&#x27;s New Rides</a></li><li class="hassub"><a href="/local-experts/darrell-burke-construction/">Darrell Burke Construction</a></li></ul></li><li class="hassub hide"><a href="/newsletter">Newsletter</a></li><li class="hassub hide"><a href="/help">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback">Send Feedback</a></li><li class="hassub"><a href="mailto:tim@wbckfm.com">E-mail Tim Collins</a></li><li class="hassub"><a href="mailto:renk@townsquaremedia.com" target="_blank">E-mail Renk</a></li><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities">Jobs</a><ul class="links submenu"><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities/">Townsquare Media Jobs</a></li><li class="hassub"><a href="/eeo/">EEO Report</a></li></ul></li><li class="hassub"><a href="/advertise">Advertise</a></li></ul></li></ul></li></ul><div class="site-menu-right"><div class="listen-live-cto-container"><a class="listen-live-cto cto has-marquee" href="/listen-live/"><span class="icon-play2"></span><div class="cto-title-container"><span class="cto-title">Listen Now</span><div class="marquee song-info-marquee"><span class="marquee-mover"><span class="song-info-artist">Sean Hannity</span></span><span class="marquee-mover-duplicate"><span class="song-info-artist">Sean Hannity</span></span></div></div></a></div><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/WBCKNewsTalk" target="_blank" data-social="youtube"><span class="icon-base icon-youtube"></span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/pages/WBCK-News-Talk-953-FM/192937086432" target="_blank" data-social="facebook"><span class="icon-base icon-facebook"></span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/wbcknews" target="_blank" data-social="twitter"><span class="icon-base icon-twitter"></span></a></li><ul class="social-subscriptions"><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div></div></div><div class="container-inner"><div class="tsm-ad tsm-ad-nav-970"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="site-content clearfix"><div class="main-content"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-157596" data-location="/michigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-157596"><div class="content-header-header"><div class="react-parallax "><div class="react-parallax-background-children" data-bottom-top="transform:translate3d(0,-20%,0);" data-top-bottom="transform:translate3d(0,20%,0);"><figure class="frameme img-tag frame-loaded"><div class="theframe" data-image="//townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg" rel="" title="" style="background-image:url(&quot;//townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg?w=980&amp;q=75&quot;)"></div></figure></div><div class="react-parallax-content"><figure class="frameme img-tag"><div class="theframe" data-image="//townsquare.media/site/656/files/2020/06/Whitmer-marching-in-Highland-Park-not-practicing-social-distancing-6-4-20-courtesy-of-the-executive-office-of-the-Governor.jpg" rel="" title=""></div></figure></div></div><div class="header"><section class="title "><h1 class="">Michigan’s Governor Whitmer Biggest Hypocrite To Hold The Office? Block Trump Rally? Join Floyd Rally!</h1></section><div class="byline"><div class="authors"><address class="author"><div class="author-image icon-user"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2018/12/Renk_Scene_Mag_Pic_Feb_2016.jpg" href="//wbckfm.com/author/renk/" rel="author" title="Renk"></a></figure></div><a class="author-name" href="//wbckfm.com/author/renk/" rel="author" title="Renk">Renk</a></address></div><time></time></div><figcaption title="courtesy of the executive office of the Governor">courtesy of the executive office of the Governor</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwbckfm.com%2Fmichigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Michigan%E2%80%99s%20Governor%20Whitmer%20Biggest%20Hypocrite%20To%20Hold%20The%20Office%3F%20Block%20Trump%20Rally%3F%20Join%20Floyd%20Rally%21%20http%3A%2F%2Fwbckfm.com%2Fmichigans-governor-whitmer-biggest-hypocrite-to-hold-the-office-block-trump-rally-join-floyd-rally%2F%3Ftrackback%3Dtwitter_mobile%20%40wbcknews" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p>Governor Whitmer might possibly be the biggest hypocrite that has ever held the office of the Governor of Michigan.&#xA0; She also showed her hand at how concerned she really is that President Trump will once again win Michigan this Fall.</p><p>We all know that there are hypocrites in politics. Some say that is the nature of politics.&#xA0; Many honest and intelligent people from all sides of the political spectrum, at times must hold their noses and vote for people who have been hypocritical to some extent. That being said, there must be some level of hypocrisy that once crossed, should make it impossible for honest, intelligent people to vote for that candidate.</p><div class="in-article-oop-container sharethrough-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><p>Governor Whitmer has surpassed that level by miles during the COVID-19 crisis.&#xA0; Throughout the pandemic, Whitmer frequently went without a mask while she was within 6 feet of people while at the same time she castigated President Trump for not wearing a mask when she thought he should.</p><p>Whitmer continued her long and corrupt journey down her yellow brick road of hypocrisy by joining a <a href="https://wbckfm.com/whitmer-believes-social-distancing-for-you-but-not-me/">George Floyd rally in Highland Park</a> on June 4th.<span class="Apple-converted-space">&#xA0; </span>Here she stood and kneeled shoulder to shoulder with people, some wearing masks others not.<span class="Apple-converted-space">&#xA0; </span>The <a href="https://www.detroitnews.com/story/news/local/michigan/2020/06/04/whitmer-appears-break-social-distance-rules-highland-park-march/3146244001/">Detroit News</a> reported the following about the rally she attended:</p><blockquote><p>Gov. Gretchen Whitmer, who&#x2019;s voiced concerns about other demonstrations potentially spreading COVID-19 in recent weeks, participated Thursday in a civil rights march in Highland Park with hundreds of people who did not follow social distancing rules.</p></blockquote><p>Now Whitmer is threatening to block President Trump from holding any campaign rallies in the state of Michigan.<span class="Apple-converted-space">&#xA0; </span>Whitmer was quoted in a <a href="https://www.detroitnews.com/story/news/politics/2020/06/22/report-whitmer-would-consider-trying-block-trump-rally/3234604001/">Detroit News</a>/AP article stating that if President Trump wanted to come and campaign in Michigan she:</p><blockquote><p>&#x201C;would think very seriously about&#x201D; trying to block Trump from hosting a rally there if he wanted to.</p></blockquote><p>She went on to say:</p><blockquote><p>We know that congregating without masks, especially at an indoor facility, is the worst thing to do in the midst of a global pandemic...I just know we have limitations on the number of people that can gather and that we&#x2019;re taking this seriously.</p></blockquote><p>Remember this is a person who just 3 weeks ago went to a George Floyd rally where she stood and kneeled shoulder to shoulder with 100&#x2019;s of people some without masks, breaking her own executive order and now she is threatening to possibly ban a Presidential candidate from the opposite party from campaigning in Michigan.<span class="Apple-converted-space">&#xA0;</span></p><p>It appears that Whitmer is very concerned, to say the least. <span class="Apple-converted-space">&#xA0; </span>Even though the polls show Biden leading President Trump in Michigan by a good margin, she must believe that President Trump will once again win Michigan.<span class="Apple-converted-space">&#xA0; </span>She must know something about the accuracy of the polls that others do not.<span class="Apple-converted-space">&#xA0; </span>Now we may know why Michigan Democrat Congresswomen Debbie Dingell stated that we should not believe the polls in Michigan.</p><p>Is Whitmer so drunk on the emergency declaration and executive order powers that she believes she can stop a presidential candidate from campaigning in Michigan?<span class="Apple-converted-space">&#xA0; </span>Put aside the fact that she violated her own executive orders when she joined the George Floyd rally.</p><p>Is this why Whitmer extended Michigan&apos;s state of emergency through July 16?<span class="Apple-converted-space">&#xA0; </span>Is she going to use those powers to deny President Trump the ability to campaign in Michigan while giving cover to Biden who is still hiding in his basement?<span class="Apple-converted-space">&#xA0;</span></p><p>As I wrote in my piece titled &#x201C;<a href="https://wbckfm.com/whitmer-extends-state-of-emergency-when-will-michigan-elected-democrats-tell-whitmer-they-are-not-useless/">Whitmer Extends State Of Emergency; When Will Michigan Elected Democrats Tell Whitmer They Are Not Useless</a>?&#x201D;<span class="Apple-converted-space">&#xA0; </span>The State of Emergency declaration gives the governor the ability to take unilateral measures without input from the State House or Senate.</p><p>Do you believe that there is any line of hypocrisy that Governor Whitmer will not cross?<span class="Apple-converted-space">&#xA0;</span></p><p>Is there any ethical code she would not break?</p><p>Is she the type of person you want leading a lemonade stand let alone a state?</p><p>Are people like her the type of person you want leading a lemonade stand let alone our country?</p><p><a href="https://wbckfm.com/author/renk/">The Live with Renk show airs Monday through Friday 9 a.m. to</a>&#xA0;<a href="https://wbckfm.com/author/renk/">noon, to let me know your thoughts call (269) 441-9595</a></p><div class="lazyload-placeholder singlePostGallery-lazyload-placeholder" data-pod="{&quot;galleryindex&quot;:&quot;0&quot;,&quot;url&quot;:&quot;/rest/carbon/uri/api/gallery/domain/wbckfm.com/galleryId/154460?filterexclusions&amp;galleryindex=0&quot;,&quot;thumbnail&quot;:&quot;//townsquare.media/site/656/files/2020/05/GettyImages-1224848076.jpg&quot;,&quot;layout&quot;:&quot;&quot;,&quot;title&quot;:&quot;Protesters at the Capital in Lansing&quot;,&quot;fullscreen&quot;:&quot;0&quot;,&quot;blingfrequency&quot;:3,&quot;portraitmode&quot;:&quot;0&quot;,&quot;galleryid&quot;:&quot;tsm-photogallery-656-154460-0&quot;}"></div></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper"><span>Filed Under<!-- -->: </span><span><a href="//wbckfm.com/tags/campaign/">campaign</a></span><span>, <a href="//wbckfm.com/tags/gretchen-whitmer/">gretchen whitmer</a></span><span>, <a href="//wbckfm.com/tags/president-trump/">president trump</a></span></div><div class="wrapper"><span>Categories<!-- -->: </span><span><a href="//wbckfm.com/category/michigan/">Michigan</a></span><span>, <a href="//wbckfm.com/category/opinion/">Opinion</a></span><span>, <a href="//wbckfm.com/category/politics/">Politics</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down"></span></div><div class="cto">Leave A Comment</div></div></div><div class="lazyload-placeholder zergnet-lazyload-placeholder" data-pod="{}"></div><div class="goto-top-container outgrow"><a class="goto-top icon-triangle-left" href="javascript:void(0);" title="Go To Top" data-index="0">Back To Top</a></div></div></div></article></div></div></div></div><aside class="main-aside"><div class="aside-inside"><section class="sidebar-section widget-ts_blogroll" id="ts_blogroll-575"><header><h2><span class="title-container">Featured</span></h2></header><div class="wrapper clearfix"><section id="ts_blogroll-575" class="blogroll carousel slider dl align-right"><div class="slider blogroll-items"><div class="sizer"></div><div class="mover slide"><article class="item title-over-image"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2020/06/Untitled-design1.jpg" href="//wbckfm.com/field-of-flowers-in-fennville/" rel="" title="The Touching Reason Behind This Field Of Flowers In Fennville"></a><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px"><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div class="content"><a href="//wbckfm.com/field-of-flowers-in-fennville/" title="The Touching Reason Behind This Field Of Flowers In Fennville" class="title">The Touching Reason Behind This Field Of Flowers In Fennville</a></div></article></div><div class="previous icon-arrow-thin-left arrow icon-base round always-visible" title="Previous"></div><div class="next icon-arrow-thin-right arrow icon-base round always-visible" title="Next"></div></div></section></div></section><section class="sidebar-section widget-fix_sidebar_marker" id="fix_sidebar_marker-97"><div class="wrapper clearfix"><div class="fix_sidebar_marker"></div></div></section><section class="sidebar-section widget-google-ads-widget" id="google-ads-widget-427"><div class="wrapper clearfix"><div class="widget-content"><div class="tsm-ad tsm-ad-300"><div id="tsm-ad-300a"><!-- dynamic ad --></div></div></div></div></section><section class="sidebar-section widget-widget_third_party_content" id="widget_third_party_content-4"><header><h2><span class="title-container">Recommended For You</span></h2></header><div class="wrapper clearfix"><div class="widget-content"><div class="third-party-content"></div></div></div></section></div></aside></div><section class="site-footer"><footer><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a title="EEO" href="/eeo/" aria-label="EEO" class="">EEO</a></li><li class=""><a title="Marketing and Advertising Solutions" href="/advertising-and-marketing-for-business/battle-creek-mi/" aria-label="Marketing and Advertising Solutions" class="">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a title="Public File" href="https://publicfiles.fcc.gov/fm-profile/wbck" class="" aria-label="Public File">Public File</a></li><li class=""><a title="Persons with disabilities who need assistance with the WBCKFM / WBCK Public File" data-title="Persons with disabilities who need assistance with the WBCKFM / WBCK Public File" href="/wbck-public-file/" aria-label="Persons with disabilities who need assistance with the WBCKFM / WBCK Public File" class="">Need Assistance</a></li><li class=""><a title="Report an Inaccuracy" href="/report-an-inaccuracy" aria-label="Report an Inaccuracy" class="">Report an Inaccuracy</a></li><li class=""><a title="Terms" href="/terms/" aria-label="Terms" class="">Terms</a></li><li class=""><a title="VIP Terms" href="/vip-terms/" aria-label="VIP Terms" class="">VIP Terms</a></li><li class=""><a title="FAQ" href="/vip-faq/" aria-label="FAQ" class="">FAQ</a></li><li class=""><a title="Contest Rules" href="/contest-rules/" aria-label="Contest Rules" class="">Contest Rules</a></li><li class=""><a title="Privacy Policy (Updated: 2/28/20)" href="/privacy/" aria-label="Privacy Policy (Updated: 2/28/20)" class="">Privacy Policy (Updated: 2/28/20)</a></li><li class=""><a title="Exercise My Data Rights" href="/privacy/preferences/" aria-label="Exercise My Data Rights" class="">Exercise My Data Rights</a></li><li class=""><a title="Contact" href="/help/" aria-label="Contact" class="">Contact</a></li><li class=""><a title="Battle Creek Business Listings" href="/battle_creek-featured-business-listings/" aria-label="Battle Creek Business Listings" class="">Battle Creek Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/WBCKNewsTalk" target="_blank" data-social="youtube"><span class="icon-youtube"></span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/wbcknews" target="_blank" data-social="twitter"><span class="icon-twitter"></span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/pages/WBCK-News-Talk-953-FM/192937086432" target="_blank" data-social="facebook"><span class="icon-facebook"></span></a></li></ul></div></div><div class="legal">2020<!-- --> <!-- -->95.3 WBCKFM<!-- -->, <a href="https://www.townsquaremedia.com">Townsquare Media</a>, Inc. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            if(!window.TSM.fn.isIe(navigator.userAgent)){
              try{
                eval('(async function(){var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.f98e05a2fb1ab4a264b745a44f08c7445be5c3b0.js?mver=4"];for(var i=0;i<dependencies.length;i++){await getFile( dependencies[i] );}})();');
              }catch(e){console.error(e);}
            }else{
              document.write('<scr'+'ipt src="//townsquare.media/public/scripts.min.js?ver=f98e05a2fb1ab4a264b745a44f08c7445be5c3b0&mver=4"></sc'+'ript>');
            }
          })(document);</script>
          
        </body>
      </html>