<!doctype html>
      <html class="single desktop layout-clean fixed-full-width" lang="en">
        <head>
          <title>Battle Creek Parole Absconder Crashes On Railroad Tracks</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="description" content="A Battle Creek man fled from Calhoun County Sheriff&#x27;s Deputies, Sunday, November 27th, crashing his car on the railroad tracks bordering Fountain Street in Battle Creek."/><meta name="keywords" content="battle creek car crash, fountain street battle creek, calhoun county sheriff&#x27;s office,articles,crime,featured,news,vehicle crash"/><meta property="fb:app_id" content="212240553635327"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:admins" content="664423889"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="Battle Creek Parole Absconder Crashes On Railroad Tracks"/><meta property="og:description" content="A Battle Creek man fled from Calhoun County Sheriff&#x27;s Deputies, Sunday, November 27th, crashing his car on the railroad tracks bordering Fountain Street in Battle Creek."/><meta property="og:url" content="https://wbckfm.com/battle-creek-parole-absconder-crashes-on-railroad-tracks/"/><meta property="og:site_name" content="95.3 WBCKFM"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/656/files/2022/11/attachment-Car-crash-1-parole-absconder-11-27-22-CROP_Calhoun-County-Sheriffs-Office_edited.jpg?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@wbcknews"/><meta name="sailthru.description" content="A Battle Creek man fled from Calhoun County Sheriff&#x27;s Deputies, Sunday, November 27th, crashing his car on the railroad tracks bordering Fountain Street in Battle Creek."/><meta name="sailthru.date" content="2022-11-29 08:52:43"/><meta name="sailthru.title" content="Battle Creek Parole Absconder Crashes On Railroad Tracks"/><meta name="sailthru.tags" content="tsmsite-wbck, tsmmarket-battlecreek, tsmtype-local, battle-creek-news, calhoun-county-news, calhoun-county-sheriffs-office, articles, crime, featured, news, vehicle-crash"/><meta name="sailthru.author" content="bradcarpenter"/><meta name="sailthru.image.full" content="https://townsquare.media/site/656/files/2022/11/attachment-Car-crash-1-parole-absconder-11-27-22-CROP_Calhoun-County-Sheriffs-Office_edited.jpg"/><meta name="sailthru.image.thumb" content="https://townsquare.media/site/656/files/2022/11/attachment-Car-crash-1-parole-absconder-11-27-22-CROP_Calhoun-County-Sheriffs-Office_edited.jpg"/><meta name="robots" content="max-image-preview:large"/><meta property="fb:pages" content="192937086432"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=838797a4b84259728d8afd49dbf4137cf6369ccc&mver=31&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.838797a4b84259728d8afd49dbf4137cf6369ccc.js?mver=31&gver=3" as="script"/><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://cdn.taboola.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/656/files/2013/12/favicon.ico"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="Fire Strikes Battle Creek Home As Holidays Approach" href="https://wbckfm.com/fire-strikes-battle-creek-home-as-holidays-approach/"/><link rel="canonical" href="https://wbckfm.com/?p=203287"/><link rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?w=57&h=57"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?w=144&h=144"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?w=72&h=72"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=838797a4b84259728d8afd49dbf4137cf6369ccc&mver=31&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
      window.TSM.fn.getCookie = window.TSM.fn.getCookie || function(n){var i="; "+document.cookie,t=i.split("; "+n+"=");if(t.length==2)return t.pop().split(";").shift()};
      window.TSM.fn.setCookie = window.TSM.fn.setCookie || function(n,t,i,r="/"){var f="",u;i&&(u=new Date,u.setTime(u.getTime()+i*864e5),f="; expires="+u.toUTCString());document.cookie=n+"="+(t||"")+f+"; path="+r};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"wbckfm.com","blogId":656,"method":"get_single","postId":203287,"postType":"post","postDateGmt":"2022-11-29 13:52:43.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>(function(w,d){
        const
          getCookie = w.TSM.fn.getCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }
      })(window, document);</script>
          <script>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</script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Battle Creek Parole Absconder Crashes On Railroad Tracks","callsign":"WBCKFM","market":"Battle Creek","sitetype":"Local","siteClassification":"Local","state":"MI","genre":"news-talk","pageType":"post","tags":"battle-creek-news,calhoun-county-news,calhoun-county-sheriffs-office","categories":"articles,crime,featured,news,vehicle-crash","mediaType":"gallery","aleph":"","userAgent":"","GaIds":"G-0S4Q1C2YLV","GaPrimaryId":"G-0S4Q1C2YLV","GaMarketRollupId":"","GaCompanyRollupId":"","GaRegionRollupId":"","GaStationRollupId":"","author":"bradcarpenter"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);w.dataLayer[0].userAgent = navigator.userAgent;
    })(window);</script>
          <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");</script>
          
        
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=WBCKFM&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <link rel="preconnect" href="https://doi3unldljdx6.cloudfront.net." crossorigin/><script type="text/javascript" src="//doi3unldljdx6.cloudfront.net./script.js" async></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=wbckfm.com&v=838797a4b84259728d8afd49dbf4137cf6369ccc&mver=31&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "wbckfm.com";ZERG.user = 751;</script>
          <script type="text/javascript">
      window._taboola = window._taboola || [];
        _taboola.push({article:"auto"});
        !function (e, f, u, i) {
          if (!document.getElementById(i)){
            e.async = 1;
            e.src = u;
            e.id = i;
            f.parentNode.insertBefore(e, f);
          }
        }(document.createElement("script"),
          document.getElementsByTagName("script")[0],
          "//cdn.taboola.com/libtrc/townsquaremediatsm-network/loader.js",
          "tb_loader_script");
        if(window.performance && typeof window.performance.mark == "function")
        {window.performance.mark("tbl_ic");}
    </script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://wbckfm.com/#organization","name":"WBCKFM","logo":{"@type":"ImageObject","@id":"https://wbckfm.com/#sitelogo","url":"//townsquare.media/site/656/files/2013/12/logo1.png"},"sameAs":["https://wbckfm.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://wbckfm.com/#website","publisher":{"@id":"https://wbckfm.com/#organization"},"name":"WBCKFM","url":"https://wbckfm.com/"},{"@context":"https://schema.org","@type":"article","headline":"Battle Creek Parole Absconder Crashes On Railroad Tracks","publisher":{"@id":"https://wbckfm.com/#organization"},"url":"https://wbckfm.com/battle-creek-parole-absconder-crashes-on-railroad-tracks/","mainEntityOfPage":{"@type":"WebPage","@id":"https://wbckfm.com/?p=203287"},"description":"A Battle Creek man fled from Calhoun County Sheriff's Deputies, Sunday, November 27th, crashing his car on the railroad tracks bordering Fountain Street in Battle Creek.","@id":"https://wbckfm.com/battle-creek-parole-absconder-crashes-on-railroad-tracks/#article","image":"//townsquare.media/site/656/files/2022/11/attachment-Car-crash-1-parole-absconder-11-27-22-CROP_Calhoun-County-Sheriffs-Office_edited.jpg","author":{"@type":"Person","name":"Brad Carpenter","sameAs":"https://wbckfm.com/author/bradcarpenter"},"keywords":["battle creek car crash","fountain street battle creek","calhoun county sheriff's office","articles","crime","featured","news","vehicle crash"],"datePublished":"2022-11-29T13:52:43.000Z","dateCreated":"2022-11-29T13:52:43.000Z","dateModified":"2022-11-29T13:52:43.000Z","isPartOf":{"@id":"https://wbckfm.com/#website"}}]}</script>
        </head>
        <body>
          <script>(function(w,d){
        const
          getCookie = window.TSM.fn.getCookie,
          setCookie = window.TSM.fn.setCookie,
          alephExpire = 365*2;
          dealWithAlephCount = () => {
            let
              alephCount = getCookie( "aleph-count" );
            if( !alephCount ){
              setCookie( "aleph-count", 1, alephExpire );
            }else{
              setCookie( "aleph-count", parseInt( alephCount )+1 );
            }
          };
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
          dealWithAlephCount();
        }else{
          w.addEventListener("message", (e) => {
            //console.log(e);
            if( e.data && e.data.aleph ){
              //console.log( "e.data.aleph", e.data.aleph );
              window.aleph = e.data.aleph;
              window.cQ = window.cQ || [];
              window.cQ.push(()=>{
                window.globalActionCreators && window.globalActionCreators.addAleph && window.globalActionCreators.addAleph( window.aleph )
              });
              setCookie( "aleph", e.data.aleph, alephExpire );
              dealWithAlephCount();
            }
          });
          let
            ifr = d.createElement( "iframe" );
          ifr.id = "aleph-iframe";
          ifr.title = "aleph";
          ifr.src = "https://cdn.production.townsquareblogs.com/aleph/";
          ifr.frameborder = "0";
          ifr.style = "display:none;"
          ifr.addEventListener("load", ()=>{
            ifr.contentWindow.postMessage({action: "getAleph"}, "https://cdn.production.townsquareblogs.com");
          });
          d.body.appendChild( ifr );
        }
      })(window, document);</script>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="leaderboard-style-default" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Quick Links:</span></li><li><a href="/radio/christmas-player">Holiday Music Player</a></li><li><a href="/ixp/690/p/stuff-the-bus-2022/">Stuff The Bus</a></li><li><a href="/seasons-eatings-2022/">Season&#x27;s Eatings</a></li><li><a href="/show/community-matters/">Community Matters</a></li><li><a href="/battle-creek-area-high-school-sports-scoreboard/">High School Sports Scores</a></li><li><a href="https://www.seizethedeal.com/cities/sw-michigan">Seize The Deal</a></li><li><a href="/app/">App</a></li><li><a href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/">Alexa</a></li><li><a href="/googlehome/">Google Home</a></li><li><a href="/tags/online-job-fair/">Online Job Fair</a></li></ul></div><div id="site-menu-bg"></div><div class="logo-next-to-logo-container"><a class="logo" itemProp="logo url" href="/" data-source="logo"><img src="//townsquare.media/site/656/files/2020/12/WBCKFM-higher-rez-v2.png" alt="95.3 WBCKFM"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/djs" data-source="nav">On-Air</a><ul class="links submenu"><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li></ul></li><li class="hassub"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a><ul class="links submenu"><li class="hassub"><a href="/radio/christmas-player/1" data-source="nav">Holiday Music Player</a></li></ul></li><li class="hassub"><a href="/radio-on-demand/" data-source="nav">Radio on Demand</a></li><li class="hassub"><a href="/category/podcasts/" data-source="nav">Podcasts</a></li><li class="hassub"><a href="/app" data-source="nav">Mobile App</a></li><li class="hassub"><a href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/" data-source="nav">Listen on Amazon Alexa</a></li></ul></li><li class="hassub"><a href="/" data-source="nav">Events</a><ul class="links submenu"><li class="hassub"><a href="https://kalamazooribfest.com/" data-source="nav" target="_blank">Kalamazoo Ribfest</a></li></ul></li><li class="hassub"><a href="/keep-checking-back-for-more-ways-to-win/" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/seasons-eatings-2022/" data-source="nav">Season&#x27;s Eatings</a></li></ul></li><li class="hassub"><a href="/battle-creek-weather/" data-source="nav">Weather</a><ul class="links submenu"><li class="hassub"><a href="/battle-creek-weather/" data-source="nav">5-Day Forecast</a></li></ul></li><li class="hassub"><a href="/category/sports/" data-source="nav">Sports</a></li><li class="hassub"><a href="/local-experts/" data-source="nav">Experts</a><ul class="links submenu"><li class="hassub"><a href="/local-experts/darrell-burke-construction/" data-source="nav">Darrell Burke Construction</a></li></ul></li><li class="hassub"><a href="/newsletter" data-source="nav">Newsletter</a></li><li class="hassub"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities" data-source="nav">Jobs</a><ul class="links submenu"><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities/" data-source="nav">Townsquare Media Jobs</a></li><li class="hassub"><a href="/eeo/" data-source="nav">EEO Report</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/djs" data-source="nav">On-Air</a><ul class="links submenu"><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li></ul></li><li class="hassub hide"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a><ul class="links submenu"><li class="hassub"><a href="/radio/christmas-player/1" data-source="nav">Holiday Music Player</a></li></ul></li><li class="hassub"><a href="/radio-on-demand/" data-source="nav">Radio on Demand</a></li><li class="hassub"><a href="/category/podcasts/" data-source="nav">Podcasts</a></li><li class="hassub"><a href="/app" data-source="nav">Mobile App</a></li><li class="hassub"><a href="/95-3-wbck-is-now-available-on-amazon-alexa-enabled-devices/" data-source="nav">Listen on Amazon Alexa</a></li></ul></li><li class="hassub hide"><a href="/" data-source="nav">Events</a><ul class="links submenu"><li class="hassub"><a href="https://kalamazooribfest.com/" data-source="nav" target="_blank">Kalamazoo Ribfest</a></li></ul></li><li class="hassub hide"><a href="/keep-checking-back-for-more-ways-to-win/" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/seasons-eatings-2022/" data-source="nav">Season&#x27;s Eatings</a></li></ul></li><li class="hassub hide"><a href="/battle-creek-weather/" data-source="nav">Weather</a><ul class="links submenu"><li class="hassub"><a href="/battle-creek-weather/" data-source="nav">5-Day Forecast</a></li></ul></li><li class="hassub hide"><a href="/category/sports/" data-source="nav">Sports</a></li><li class="hassub hide"><a href="/local-experts/" data-source="nav">Experts</a><ul class="links submenu"><li class="hassub"><a href="/local-experts/darrell-burke-construction/" data-source="nav">Darrell Burke Construction</a></li></ul></li><li class="hassub hide"><a href="/newsletter" data-source="nav">Newsletter</a></li><li class="hassub hide"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities" data-source="nav">Jobs</a><ul class="links submenu"><li class="hassub"><a href="/townsquare-media-kalamazoo-job-opportunities/" data-source="nav">Townsquare Media Jobs</a></li><li class="hassub"><a href="/eeo/" data-source="nav">EEO Report</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li></ul></li></ul><div class="site-menu-right"><a class="listen-live-cto cto" style="min-width:300px"></a><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/WBCKNewsTalk" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/953WBCK" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/wbcknews" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li><li><ul class="social-subscriptions"><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></li></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop2"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970" aria-label="advertisement"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-203287" data-location="/battle-creek-parole-absconder-crashes-on-railroad-tracks/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-203287"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="Battle Creek Parole Absconder Crashes On Railroad Tracks"><img src="//townsquare.media/site/656/files/2022/11/attachment-Car-crash-1-parole-absconder-11-27-22-CROP_Calhoun-County-Sheriffs-Office_edited.jpg?w=980&amp;q=75" alt="Battle Creek Parole Absconder Crashes On Railroad Tracks"/></figure></div><div class="header"><section class="title "><h1 class="">Battle Creek Parole Absconder Crashes On Railroad Tracks</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2020/09/MeDave_200918.jpg" href="//wbckfm.com/author/bradcarpenter/" rel="author"><figcaption class="visually-hidden">Brad Carpenter</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//wbckfm.com/author/bradcarpenter/" rel="author">Brad Carpenter</a><time dateTime="2022-11-29 13:52:43 +0000">Published: November 29, 2022</time></div></div></div><figcaption>Calhoun County Sheriff's Office</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwbckfm.com%2Fbattle-creek-parole-absconder-crashes-on-railroad-tracks%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Battle%20Creek%20Parole%20Absconder%20Crashes%20On%20Railroad%20Tracks%20http%3A%2F%2Fwbckfm.com%2Fbattle-creek-parole-absconder-crashes-on-railroad-tracks%2F%3Ftrackback%3Dtwitter_mobile%20%40wbcknews" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p><span data-contrast="auto">Calhoun County Sheriff&#x2019;s Deputies were on patrol, at around 9 PM the evening of Sunday, November 27</span><span data-contrast="auto"><span data-fontsize="14">th</span></span><span data-contrast="auto">, when something familiar caught their eye in the 500-block of Upton Avenue. In the parking lot of a local Springfield business was a vehicle that had fled from law enforcement earlier in the week. And another interesting fact, the driver was a 44-year-old Battle Creek man who was currently being sought for an active parole absconder warrant with the Michigan Department of Corrections. Instead of laying low and giving the known vehicle a rest from the streets of Battle Creek, the wanted absconder was now passing time in the parking lot, unaware that Calhoun County Sheriff&#x2019;s Deputies were to shortly arrive and push his adrenaline secretion to a higher level.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:360}">&#xA0;</span></p><p><span data-contrast="auto">As deputies approached the parked vehicle, the suspect weighed his options and chose to flee the scene, traveling southeast on Upton Avenue. The pursuit ended a couple of minutes later, about a mile and a half down the road, when the suspect crashed into a guardrail on Fountain Street, overturning and landing on the railroad tracks. He remained trapped in the vehicle as deputies called for an ambulance and fire personnel, and alerted dispatch to contact railroad authorities so that any trains in the area could be halted. It is probably at this time that the parole absconder had a &#x201C;Come to Jesus&#x201D; moment as he gazed down the tracks, hoping not to see the gleam of approaching lights.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:360}">&#xA0;</span></p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><div class="branded-app-shortcode-inarticle"><div class="logo-wrap"><img src="https://townsquare.media/wp-content/uploads/2019/05/WBCKFM.png?w=100"/></div><div class="phone-input"><div><div><div class="description-wrap desc-short"><div class="description">Get our free mobile app</div></div></div><div class="bap-enter-number"><input type="text" placeholder="Enter mobile number" maxLength="10"/></div></div></div><div style="clear:both"></div></div><p><span data-contrast="auto">When Battle Creek Firefighters arrived on the scene, they began the process of extricating the trapped driver by pealing back the roof from the badly damaged vehicle. Once freed from the mangled mess, he was transported by LifeCare Ambulance to the hospital, where he was examined and declared fit to be lodged in the Calhoun County Jail on an active parole absconder warrant, including charges of Fleeing and Eluding from police and Driving While License Suspended.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:360}">&#xA0;</span></p><div class="single-post-image "><figure class="img-tag has-sizer aligncenter" style="max-width:900px"><div class="frame-sizer" style="padding-top:133.33333333333334%"></div><div class="theframe" data-image="//townsquare.media/site/656/files/2022/11/attachment-Car-crash-2-parole-absconder-11-27-22_Calhoun-County-Sheriffs-Office.jpg" rel=""><span class="visually-hidden">Parole Absconder Vehicle Crash</span></div><figcaption>Calhoun County Sheriff's Office</figcaption><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px" focusable="false" role="img" aria-labelledby="loading-anim-title"><title id="loading-anim-title">loading...</title><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div></div></div><div class="single-post-image "><figure class="img-tag has-sizer aligncenter" style="max-width:900px"><div class="frame-sizer" style="padding-top:133.33333333333334%"></div><div class="theframe" data-image="//townsquare.media/site/656/files/2022/11/attachment-Car-crash-3-parole-absconder-11-27-22_Calhoun-County-Sheriffs-Office.jpg" rel=""><span class="visually-hidden">Parole Absconder Vehicle Crash</span></div><figcaption>Calhoun County Sheriff's Office</figcaption><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px" focusable="false" role="img" aria-labelledby="loading-anim-title"><title id="loading-anim-title">loading...</title><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div></div></div><div class="photogallery-wrapper"><h2 class="photogallery-title">Gilmore Car Museum "Winter Wonderland" Light Display</h2><div class="photogallery-description"><div>The Gilmore's "Winter Wonderland: A Holiday Lights Spectacular" is now underway at the Gilmore Car Museum, from 5-9pm. Walk through the museum displays, through the various experiences outside, and ride through the lights in classic Gilmore Cars.</div></div></div></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//wbckfm.com/tags/battle-creek-news/">Battle Creek News</a></span><span>, <a href="//wbckfm.com/tags/calhoun-county-news/">Calhoun County News</a></span><span>, <a href="//wbckfm.com/tags/calhoun-county-sheriffs-office/">calhoun county sheriff's office</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//wbckfm.com/category/articles/">Articles</a></span><span>, <a href="//wbckfm.com/category/crime/">Crime</a></span><span>, <a href="//wbckfm.com/category/featured/">Featured</a></span><span>, <a href="//wbckfm.com/category/news/">News</a></span><span>, <a href="//wbckfm.com/category/vehicle-crash/">Vehicle Crash</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div></div></div></article><div class="tsm-ad tsm-ad-728 tsm-ad-in-between-article" aria-label="advertisement"><div id="tsm-ad-728c-1"><!-- dynamic ad --></div></div><section id="ts_blogroll-afterpost" class="blogroll row-standard-3x ts_blogroll outgrow"><header class="header-band"><h2 class="">More From WBCKFM</h2></header><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2017/04/Fire-Engine-3-BCFD.jpg" href="/fire-strikes-battle-creek-home-as-holidays-approach/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Fire Strikes Battle Creek Home As Holidays Approach</figcaption></a></figure><div class="content"><a href="/fire-strikes-battle-creek-home-as-holidays-approach/" class="title" data-source="blogroll">Fire Strikes Battle Creek Home As Holidays Approach</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2022/11/attachment-KCC-phlebotomy-training.jpg" href="/kcc-offers-free-phlebotomy-training/" rel="" data-source="blogroll"><figcaption class="visually-hidden">KCC Offers Free Phlebotomy Training</figcaption></a></figure><div class="content"><a href="/kcc-offers-free-phlebotomy-training/" class="title" data-source="blogroll">KCC Offers Free Phlebotomy Training</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/691/files/2020/11/GettyImages-625708976.jpg" href="/free-thanksgiving-meals-around-battle-creek-and-kazoo/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Free Thanksgiving Meals Around Battle Creek And Kalamazoo</figcaption></a></figure><div class="content"><a href="/free-thanksgiving-meals-around-battle-creek-and-kazoo/" class="title" data-source="blogroll">Free Thanksgiving Meals Around Battle Creek And Kalamazoo</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2022/11/attachment-Hooligans-2_YouTube.jpg" href="/the-hooligans-flight-team-receive-vintage-planes-from-wmu/" rel="" data-source="blogroll"><figcaption class="visually-hidden">The Hooligans Flight Team Receive Vintage Planes From WMU</figcaption></a></figure><div class="content"><a href="/the-hooligans-flight-team-receive-vintage-planes-from-wmu/" class="title" data-source="blogroll">The Hooligans Flight Team Receive Vintage Planes From WMU</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/44/files/2020/04/RS23635_GettyImages-548979711-scr.jpg" href="/albion-college-grad-takes-a-stroll-in-outer-space/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Albion College Grad Takes A Stroll In Outer Space</figcaption></a></figure><div class="content"><a href="/albion-college-grad-takes-a-stroll-in-outer-space/" class="title" data-source="blogroll">Albion College Grad Takes A Stroll In Outer Space</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/757/files/2016/05/Vaping1.jpg" href="/four-vape-shops-targeted-in-battle-creek-sting-operation/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Four Vape Shops Targeted In Battle Creek Sting Operation</figcaption></a></figure><div class="content"><a href="/four-vape-shops-targeted-in-battle-creek-sting-operation/" class="title" data-source="blogroll">Four Vape Shops Targeted In Battle Creek Sting Operation</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2021/01/RS40952_GettyImages-525789257-scr.jpg" href="/michigan-meteor-shower-viewing-is-sketchy-this-weekend/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Michigan Meteor Shower Viewing Is Sketchy This Weekend</figcaption></a></figure><div class="content"><a href="/michigan-meteor-shower-viewing-is-sketchy-this-weekend/" class="title" data-source="blogroll">Michigan Meteor Shower Viewing Is Sketchy This Weekend</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/656/files/2022/11/attachment-Vintage-Santa_Fox-Photos-GettyImages-2716491.jpg" href="/winter-wanderland-to-premier-in-downtown-battle-creek/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Winter Wanderland To Premier In Downtown Battle Creek</figcaption></a></figure><div class="content"><a href="/winter-wanderland-to-premier-in-downtown-battle-creek/" class="title" data-source="blogroll">Winter Wanderland To Premier In Downtown Battle Creek</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/84/files/2022/07/attachment-RS9771_457516027.jpg" href="/battle-creek-man-injured-from-violent-early-morning-assault/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Battle Creek Man Injured From Violent Early Morning Assault</figcaption></a></figure><div class="content"><a href="/battle-creek-man-injured-from-violent-early-morning-assault/" class="title" data-source="blogroll">Battle Creek Man Injured From Violent Early Morning Assault</a></div></article></div></section></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/eeo/" aria-label="EEO">EEO</a></li><li class=""><a href="/advertising-and-marketing-for-business/battle-creek-mi/" aria-label="Marketing and Advertising Solutions">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a href="https://publicfiles.fcc.gov/fm-profile/WBCK" aria-label="WBCKFM Public File">Public File</a></li><li class="last-one-merge"><a href="/wbck-public-file/" aria-label="Persons with disabilities who need assistance with the WBCKFM / WBCK Public File">Need Assistance</a></li><li class=""><a href="/fcc-applications/" aria-label="FCC Applications">FCC Applications</a></li><li class=""><a href="/report-an-inaccuracy" aria-label="Report an Inaccuracy">Report an Inaccuracy</a></li><li class=""><a href="/terms/" aria-label="Terms">Terms</a></li><li class=""><a href="/contest-rules/" aria-label="Contest Rules">Contest Rules</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/digital-accessibility-statement/" aria-label="Accessibility Statement">Accessibility Statement</a></li><li class=""><a href="/privacy/preferences/" aria-label="Exercise My Data Rights">Exercise My Data Rights</a></li><li class=""><a href="/help/" aria-label="Contact">Contact</a></li><li class=""><a href="/battle_creek-featured-business-listings/" aria-label="Battle Creek Business Listings">Battle Creek Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/WBCKNewsTalk" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/953WBCK" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/wbcknews" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->95.3 WBCKFM<a href="https://www.townsquaremedia.com">, Townsquare Media, Inc</a>. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-interstitial" aria-label="advertisement"><div id="tsm-ad-interstitial"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({flush: true});
    </script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.838797a4b84259728d8afd49dbf4137cf6369ccc.js?mver=31&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=838797a4b84259728d8afd49dbf4137cf6369ccc" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>